transport 1.0.6

Dart native
Flutter Android iOS

A starting point for Dart libraries or applications.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 78 out of 142 API elements (54.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:transport/transport.dart that imports:
  • package:transport/src/transport/bridge/bridge_client_transaction.dart that imports:
  • package:transport/src/transport/bridge/bridge_socket_bundle.dart that imports:
  • package:transport/src/transport/bridge/bridge_cmd.dart that imports:
  • package:transport/src/socket_writer.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

INFO: Unused import: 'dart:math'.

lib/src/console_log_interface.dart:1:8

  ╷
1 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/console_log_interface.dart

INFO: Unused import: 'dart:convert'.

lib/src/socket_writer.dart:3:8

  ╷
3 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/socket_writer.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_cmd^1.0.51.0.51.0.5
encrypt^4.0.04.0.34.1.0
pointycastle^1.0.21.0.22.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
asn1lib-0.6.50.8.1
charcode-1.1.31.1.3
clock-1.0.11.0.1
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
meta-1.2.31.2.3
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on pointycastle does not support the latest published version `2.0.0`

pubspec.yaml:11:17

   ╷
11 │   pointycastle: ^1.0.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

A starting point for Dart libraries or applications.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

a1950207@gmail.com

License

BSD (LICENSE)

Dependencies

console_cmd, encrypt, pointycastle

More

Packages that depend on transport