transport 1.0.6

  • Readme
  • Changelog
  • Installing
  • 48

Transport #

Create server, transport socket data to specify server

Import #

add in pubspec.yaml, like this:

transport: ^1.0.5

Transport server #

Use for data transport, As follows:

Your connection -> TransportServer -> RemoteServer

Proxy Server #

1.0.0 #

  • Initial version, provide transport server:

    1. ProxyServer
    2. TransportServer
    3. TransportBridge

1.0.1 #

  • export classes.....

1.0.2 #

  • export console_log_interface

1.0.3 #

  • allow proxy server select cache...

1.0.4 #

  • refactor all... provide transport server as follows:

    1. HttpProxyServer
    2. ProxyServer
    3. BridgeClientServer
    4. BridgeServer
  • Bridge Server can use RSA crypt at hand-shake step.

1.0.5 #

  • export HttpProxyServer

1.0.6 #

  • allow bridge client specify peer address & port
  • allow bridge client refuse response.
  • fix intranet not access problem

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  transport: ^1.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:transport/transport.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:transport/transport.dartpackage:transport/src/transport/bridge/bridge_client_transaction.dartpackage:transport/src/transport/bridge/bridge_socket_bundle.dartpackage:transport/src/transport/bridge/bridge_cmd.dartpackage:transport/src/socket_writer.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:transport/transport.dartpackage:transport/src/transport/bridge/bridge_client_transaction.dartpackage:transport/src/transport/bridge/bridge_socket_bundle.dartpackage:transport/src/transport/bridge/bridge_cmd.dartpackage:transport/src/socket_writer.dartdart:io

Health suggestions

Fix lib/src/console_log_interface.dart. (-0.50 points)

Analysis of lib/src/console_log_interface.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:math'.

Fix lib/src/socket_writer.dart. (-0.50 points)

Analysis of lib/src/socket_writer.dart reported 1 hint:

line 3 col 8: Unused import: 'dart:convert'.

Format lib/src/buffer_reader.dart.

Run dartfmt to format lib/src/buffer_reader.dart.

Fix additional 17 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/encrypt/rsa.dart (Run dartfmt to format lib/src/encrypt/rsa.dart.)
  • lib/src/encrypt/vl.dart (Run dartfmt to format lib/src/encrypt/vl.dart.)
  • lib/src/isolate_runner.dart (Run dartfmt to format lib/src/isolate_runner.dart.)
  • lib/src/log_interface.dart (Run dartfmt to format lib/src/log_interface.dart.)
  • lib/src/mix_key.dart (Run dartfmt to format lib/src/mix_key.dart.)
  • lib/src/node_chain.dart (Run dartfmt to format lib/src/node_chain.dart.)
  • lib/src/server.dart (Run dartfmt to format lib/src/server.dart.)
  • lib/src/socket_bundle.dart (Run dartfmt to format lib/src/socket_bundle.dart.)
  • lib/src/stream_reader.dart (Run dartfmt to format lib/src/stream_reader.dart.)
  • lib/src/stream_transport.dart (Run dartfmt to format lib/src/stream_transport.dart.)
  • lib/src/transport/bridge/bridge_client_transaction.dart (Run dartfmt to format lib/src/transport/bridge/bridge_client_transaction.dart.)
  • lib/src/transport/bridge/bridge_cmd.dart (Run dartfmt to format lib/src/transport/bridge/bridge_cmd.dart.)
  • lib/src/transport/bridge/bridge_server_transaction.dart (Run dartfmt to format lib/src/transport/bridge/bridge_server_transaction.dart.)
  • lib/src/transport/bridge/bridge_socket_bundle.dart (Run dartfmt to format lib/src/transport/bridge/bridge_socket_bundle.dart.)
  • lib/src/transport/proxy/http_proxy_transaction.dart (Run dartfmt to format lib/src/transport/proxy/http_proxy_transaction.dart.)
  • lib/src/transport/proxy/proxy_transaction.dart (Run dartfmt to format lib/src/transport/proxy/proxy_transaction.dart.)
  • lib/transport.dart (Run dartfmt to format lib/transport.dart.)

Maintenance suggestions

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and transport.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
console_cmd ^1.0.5 1.0.5
encrypt ^4.0.0 4.0.2
pointycastle ^1.0.2 1.0.2
Transitive dependencies
args 1.6.0
asn1lib 0.6.5
charcode 1.1.3
clock 1.0.1
collection 1.14.13
convert 2.1.1
crypto 2.1.5
meta 1.1.8
typed_data 1.2.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0