test_ext 0.0.1

Dart native js
Flutter Android iOS web

The extensions for test

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 15 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/test_ext.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
test^1.9.21.15.41.15.4
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-9.0.09.0.0
analyzer-0.40.20.40.2
args-1.6.01.6.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
coverage-0.14.10.14.1
crypto-2.1.52.1.5
glob-1.2.01.2.0
http-0.12.20.12.2
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.180.2.18
test_core-0.3.11+10.3.11+1
typed_data-1.2.01.2.0
vm_service-4.2.05.1.0+1
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.30.7.3
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

The extensions for test

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

yongjhih@gmail.com

License

unknown (LICENSE)

Dependencies

test

More

Packages that depend on test_ext