tellam 0.1.5

Flutter Android iOS

Tellam flutter package to integrate FAQ and live support chat using firebase.

1
likes
70 / 110
pub points
73 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 45 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/header_title_tile.dart that imports:
  • package:tellam/src/database/models/faq_topic.dart that imports:
  • package:floor/floor.dart that imports:
  • package:floor/src/sqflite_database_factory.dart that imports:
  • package:sqflite/sqlite_api.dart that declares support for platforms: Android, iOS, macOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/header_title_tile.dart that imports:
  • package:tellam/src/database/models/faq_topic.dart that imports:
  • package:floor/floor.dart that imports:
  • package:floor/src/sqflite_database_factory.dart that imports:
  • package:sqflite/sqlite_api.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform Linux

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/header_title_tile.dart that imports:
  • package:tellam/src/database/models/faq_topic.dart that imports:
  • package:floor/floor.dart that imports:
  • package:floor/src/sqflite_database_factory.dart that imports:
  • package:sqflite/sqlite_api.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform macOS

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/chat_banner_tile.dart that imports:
  • package:tellam/src/widgets/oval_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/chat_banner_tile.dart that imports:
  • package:tellam/src/widgets/oval_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:tellam/tellam.dart that imports:
  • package:tellam/src/views/help_page.dart that imports:
  • package:tellam/src/widgets/chat_banner_tile.dart that imports:
  • package:tellam/src/widgets/oval_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/database/AppDatabase.g.dart:424:16

    ╷
424 │   static final _faq_topicsMapper = (Map<String, dynamic> row) =>
    │                ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/database/AppDatabase.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bubble^1.1.9+11.1.9+11.1.9+1
cached_network_image^2.2.0+12.3.32.3.3
firebase_database^4.0.04.1.14.1.1
floor^0.13.00.13.00.16.0
flutterflutter0.0.00.0.0
flutter_gradient_colors^1.0.01.0.01.0.0
flutter_html^1.0.21.0.21.0.2
flutter_icons^1.0.0+11.1.01.1.0
flutter_svg^0.18.00.18.10.19.1
intl^0.16.00.16.10.16.1
rxdart^0.24.10.24.10.24.1
sqflite^1.3.01.3.1+21.3.1+2
timeago^2.0.262.0.272.0.27
url_launcher^5.5.05.7.55.7.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
chewie-0.9.100.9.10
chewie_audio-1.0.0+11.0.0+1
clock-1.0.11.1.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
crypto-2.1.52.1.5
css_colors-1.0.21.0.2
csslib-0.16.20.16.2
ffi-0.1.30.1.3
file-5.2.15.2.1
firebase-7.3.27.3.2
firebase_core-0.5.0+10.5.0+1
firebase_core_platform_interface-2.0.02.0.0
firebase_core_web-0.2.00.2.0
floor_annotation-0.8.00.10.0
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.0.02.0.0
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.14.0+4
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.10-nullsafety.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
octo_image-0.3.00.3.0
open_iconic_flutter-0.3.00.3.0
path-1.7.01.8.0-nullsafety.1
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider-1.6.211.6.21
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
quiver-2.1.32.1.3
screen-0.0.50.0.5
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
sqflite_common-1.0.2+11.0.2+1
sqflite_common_ffi-1.1.11.1.1
sqlite3-0.1.70.1.7
stack_trace-1.9.51.10.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.1
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
url_launcher_linux-0.0.1+10.0.1+1
url_launcher_macos-0.0.1+80.0.1+8
url_launcher_platform_interface-1.0.81.0.8
url_launcher_web-0.1.4+10.1.4+1
url_launcher_windows-0.0.1+10.0.1+1
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
video_player-0.10.12+50.11.1+2
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.2.0+1
webview_flutter-0.3.241.0.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.0` on floor does not support the latest published version `0.16.0`

pubspec.yaml:14:10

   ╷
14 │   floor: ^0.13.0
   │          ^^^^^^^
   ╵
The constraint `^0.18.0` on flutter_svg does not support the latest published version `0.19.1`

pubspec.yaml:21:16

   ╷
21 │   flutter_svg: ^0.18.0
   │                ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs