tectonic_location 3.0.3
tectonic_location: ^3.0.3 copied to clipboard

A Flutter plugin to easily handle realtime location in iOS and Android. Provides settings for optimizing performance or battery.

0
likes
100/ 130
pub points
10%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 11 API elements (72.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:tectonic_location/tectonic_location.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.1.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0,[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7 and test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0, test >=1.3.0 <1.12.0-∞ or >=1.16[...]
And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test >=1.3.0 <1.14.5-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typ[...]
And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test >=1.3.0 <1.15.3-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typ[...]
And because test >=1.15.3 <1.15.5 depends on test_api 0.2.18 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test >=1.3.0 <1.16.0-nullsafety.19 requires typed_data >=1.3.0-null[...]
And because test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19 and every version of flutter_test from sdk depends on boolean_selector 2.1.0, if test >=1.3.0 <1.16.6 and flutter_test a[...]
And because every version of flutter_test from sdk depends on both test_api 0.4.2 and typed_data 1.3.0, flutter_test from sdk is incompatible with test >=1.3.0 <1.16.6.
And because test >=1.16.6 depends on shelf_static ^1.0.0 which depends on http_parser ^4.0.0, if flutter_test any from sdk and test >=1.3.0 then http_parser ^4.0.0.
[2 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

0
likes
100
pub points
10%
popularity

A Flutter plugin to easily handle realtime location in iOS and Android. Provides settings for optimizing performance or battery.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, location_platform_interface, location_web, meta

More

Packages that depend on tectonic_location