tankerkoenig_dart 1.0.3 copy "tankerkoenig_dart: ^1.0.3" to clipboard
tankerkoenig_dart: ^1.0.3 copied to clipboard

A dart package to retrieve data from german tankerkoenig v4 API. Get petrol stations, gas prices and the corresponding location from their API.

4
likes
80/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/jayjah/tankerkoenig_dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 65 API elements (27.7 %) have documentation comments.

Some symbols that are missing documentation: tankerkoenig_dart, tankerkoenig_dart.Fuel.category, tankerkoenig_dart.Fuel.Fuel.fromJson, tankerkoenig_dart.Fuel.lastChange, tankerkoenig_dart.Fuel.listFromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: The argument type 'String' can't be assigned to the parameter type 'Uri'.

lib/src/api/client/client.chopper.dart:33:7

   ╷
33 │       $url,
   │       ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/api/client/client.chopper.dart

ERROR: The argument type 'String' can't be assigned to the parameter type 'Uri'.

lib/src/api/client/client.chopper.dart:52:7

   ╷
52 │       $url,
   │       ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/api/client/client.chopper.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
chopper ^5.1.0 5.2.0 7.1.1+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.1.0` on chopper does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions chopper to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

4
likes
80
pub points
0%
popularity

Publisher

verified publishermarkus.jayjah.de

A dart package to retrieve data from german tankerkoenig v4 API. Get petrol stations, gas prices and the corresponding location from their API.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

chopper

More

Packages that depend on tankerkoenig_dart