tabpanel 0.1.0
tabpanel: ^0.1.0 copied to clipboard

Tabbed inferface with support for nested and resizeable panels.

3
likes
70 / 110
pub points
24 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 67 out of 95 API elements (70.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The named parameter 'onDragUpdate' isn't defined.

lib/src/tab_panel_widget.dart:112:23

    ╷
112 │                       onDragUpdate: (details) => panel.updateSize(i, details),
    │                       ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/tab_panel_widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_mobx^1.1.0+21.1.0+21.1.0+2
mobx^1.2.1+41.2.1+41.2.1+4
uuid^2.2.22.2.23.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.2` on uuid does not support the latest published version `3.0.1`

pubspec.yaml:12:9

   ╷
12 │   uuid: ^2.2.2
   │         ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

3
likes
70
pub points
24%
popularity

Tabbed inferface with support for nested and resizeable panels.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

rudoka@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_mobx, mobx, uuid

More

Packages that depend on tabpanel