surf_mwwm 2.0.2 copy "surf_mwwm: ^2.0.2" to clipboard
surf_mwwm: ^2.0.2 copied to clipboard

discontinued

Reflection of widget in a single entity. Includes: surf_injector, relation, mwwm, rxdart.

21
likes
80/ 160
pub points
61%
popularity

We analyzed this package 25 hours ago, and awarded it 80 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/surfstudio/SurfGear/tree/main/packages/surf_mwwm was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/surfstudio/SurfGear/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: surf_mwwm,
    • contains a version property, and,
    • does not contain a publish_to property.

Could not find any pubspec.yaml in the repository.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

138 out of 166 API elements (83.1 %) have documentation comments.

Some symbols that are missing documentation: surf_mwwm, surf_mwwm.Broadcast.performInternal, surf_mwwm.CoreMwwmWidget.createWidgetState, surf_mwwm.DataErrorWidgetBuilder, surf_mwwm.DataWidgetBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The name 'WidgetState' is defined in the libraries 'package:flutter/src/widgets/widget_state.dart (via package:flutter/widgets.dart)' and 'package:mwwm/src/widget_state.dart (via package:mwwm/mwwm.dart)'.

lib/src/mwwm_widget.dart:35:20

   ╷
35 │   /// Builder for [WidgetState]
   │                    ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mwwm_widget.dart

ERROR: The name 'WidgetState' is defined in the libraries 'package:flutter/src/widgets/widget_state.dart (via package:flutter/widgets.dart)' and 'package:mwwm/src/widget_state.dart (via package:mwwm/mwwm.dart)'.

lib/src/mwwm_widget.dart:47:32

   ╷
47 │ /// Hidden widget that create [WidgetState]
   │                                ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mwwm_widget.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
mwwm ^2.0.0-dev.1 2.0.0 2.0.0
relation ^3.1.0-dev.1 3.1.0 3.1.0
rxdart ^0.27.0 0.27.7 0.28.0
surf_injector ^1.0.0 1.0.0 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.0` on rxdart does not support the stable version `0.28.0`, that was published 27 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • AMBIGUOUS_IMPORT - lib/src/mwwm_widget.dart:35:20 - The name 'WidgetState' is defined in the libraries 'package:flutter/src/widgets/widget_state.dart (via package:flutter/widgets.dart)' and 'package:mwwm/src/widget_state.dart (via package:mwwm/mwwm.dart)'.
  • AMBIGUOUS_IMPORT - lib/src/mwwm_widget.dart:47:32 - The name 'WidgetState' is defined in the libraries 'package:flutter/src/widgets/widget_state.dart (via package:flutter/widgets.dart)' and 'package:mwwm/src/widget_state.dart (via package:mwwm/mwwm.dart)'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

21
likes
80
pub points
61%
popularity

Publisher

verified publishersurf.ru

Reflection of widget in a single entity. Includes: surf_injector, relation, mwwm, rxdart.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

flutter, mwwm, relation, rxdart, surf_injector

More

Packages that depend on surf_mwwm