super_clipboard 0.8.17 copy "super_clipboard: ^0.8.17" to clipboard
super_clipboard: ^0.8.17 copied to clipboard

Comprehensive clipboard access package for Flutter. Supports reading and writing of rich text, images and other formats.

0.8.17 #

0.8.16 #

0.8.15 #

0.8.14 #

  • Bump "super_clipboard" to 0.8.14.

0.8.13 #

0.8.12 #

0.8.11 #

0.8.10 #

0.8.9 #

0.8.8 #

  • FEAT: add flac and ogg format definitions (#331).

0.8.7 #

0.8.6 #

0.8.5 #

  • FEAT: add m4a format definition (#306).

0.8.4 #

0.8.3 #

  • updated cargokit

0.8.2+1 #

0.8.2 #

  • FIX: correct GIF uniform type identifier (#276).
  • FEAT: improve performance with large number of items (#283).

0.8.1 #

0.8.0 #

0.8.0-dev.3 #

  • FEAT: implement copy and cut events (#253).

0.8.0-dev.2 #

  • Bump "super_clipboard" to 0.8.0-dev.2.

0.8.0-dev.1 #

  • FEAT: preventDefault for paste event (#249).
  • FEAT: implement paste event on web (#246).

0.7.3 #

0.7.2 #

0.7.1 #

  • Bump "super_clipboard" to 0.7.1.

0.7.0 #

0.7.0-dev.7 #

  • Bump "super_clipboard" to 0.7.0-dev.7.

0.7.0-dev.6 #

  • FEAT: add support for epub and md (#205).

0.7.0-dev.5 #

  • FIX: readFile fails when item is a String (#202).

0.7.0-dev.4 #

0.7.0-dev.3 #

0.7.0-dev.2 #

0.7.0-dev.1 #

  • FIX: do not use path dependencies for published packages in pubspec.yaml (#183).

0.6.4 #

  • FIX: update engine_context dependency.

0.6.3 #

  • Bump "super_clipboard" to 0.6.3.

0.6.2 #

  • Bump "super_clipboard" to 0.6.2.

0.6.1 #

  • DOCS: update comments.

0.6.0 #

Note: This release has breaking changes.

  • FIX: correct imports and add missing exports (#155).
  • FEAT: improve compatibility with current Flutter main (#163).
  • BREAKING FIX: correct typos and spelling in code (#156).
  • BREAKING CHORE: remove Pair and replace it with dart 3 record (#157).

0.5.0 #

Note: This release has breaking changes.

  • DOCS: [android] mention minSdkVersion in readme (#150).
  • DOCS: update NDK installation information (#149).
  • BREAKING FEAT: upgrade to Dart 3 and jni 0.21.1 (#138).

0.4.0 #

  • Bump "super_clipboard" to 0.4.0.

0.3.0+2 #

  • Update a dependency to the latest release.

0.3.0+1 #

  • Update a dependency to the latest release.

0.3.0 #

  • FIX: [android] build failing with proguard enabled (#114).
  • FEAT: add htmlFile format (#107).
  • FEAT: make format in DataReader.getFile optional (#90).

0.2.3+1 #

  • Update a dependency to the latest release.

0.2.3 #

  • FEAT: add Formats.plainTextFile.

0.2.1+3 #

  • Update a dependency to the latest release.

0.2.1+2 #

  • Update a dependency to the latest release.

0.2.1+1 #

  • Update a dependency to the latest release.

0.2.1 #

  • Bump "super_clipboard" to 0.2.1.

0.2.0 #

Note: This release has breaking changes.

  • FIX: properly unitialize com on windows.
  • FEAT: declare more well-known formats (#58).
  • FEAT: cleanup receiving of files (#54).
  • FEAT: initialize ole on windows (#51).
  • BREAKING FEAT: implement unified content receiving (#47).
  • BREAKING FEAT: refactor format (#46).

0.1.7+6 #

  • Update a dependency to the latest release.

0.1.7+5 #

  • Update a dependency to the latest release.

0.1.7+4 #

  • Update a dependency to the latest release.

0.1.7+3 #

  • Update a dependency to the latest release.

0.1.7+2 #

  • FIX: minor clean-ups.

0.1.7+1 #

  • Update a dependency to the latest release.

0.1.7 #

  • FEAT: migrate to irondash (#27).

0.1.6+2 #

  • Update a dependency to the latest release.

0.1.6+1 #

  • Update a dependency to the latest release.

0.1.5 #

  • Fix compatibility with NDK 23+

0.1.4 #

  • FEAT: add_super_keyboard_layout (#20).

0.1.3+1 #

  • Update a dependency to the latest release.

0.1.3 #

  • Improve documentation.

0.1.2 #

  • Improve documentation.

0.1.1 #

  • Improve documentation.

0.1.0 #

  • Initial public release.
167
likes
160
pub points
96%
popularity

Publisher

verified publishernativeshell.dev

Comprehensive clipboard access package for Flutter. Supports reading and writing of rich text, images and other formats.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, meta, super_native_extensions

More

Packages that depend on super_clipboard