stripe_apple_pay 1.0.0 copy "stripe_apple_pay: ^1.0.0" to clipboard
stripe_apple_pay: ^1.0.0 copied to clipboard

PlatformiOS

Create chargeable stripe tokens using Apple Pay

1
likes
130/ 140
pub points
27%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

20 out of 39 API elements (51.3 %) have documentation comments.

Some symbols that are missing documentation: stripe_apple_pay, stripe_apple_pay.ApplePayButton.supported, stripe_apple_pay.ApplePayItem.amount, stripe_apple_pay.ApplePayItem.copyWith, stripe_apple_pay.ApplePayItem.label.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:stripe_apple_pay/stripe_apple_pay.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:stripe_apple_pay/stripe_apple_pay.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:stripe_apple_pay/stripe_apple_pay.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:stripe_apple_pay/stripe_apple_pay.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:stripe_apple_pay/stripe_apple_pay.dart that declares support for platforms: iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
130
pub points
27%
popularity

Publisher

unverified uploader

Create chargeable stripe tokens using Apple Pay

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on stripe_apple_pay