string_validator 0.3.0 copy "string_validator: ^0.3.0" to clipboard
string_validator: ^0.3.0 copied to clipboard

Dart library for validating and sanitizing strings, especially those from user input.

354
likes
130/ 140
pub points
98%
popularity

We analyzed this package 18 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

48 out of 49 API elements (98.0 %) have documentation comments.

Some symbols that are missing documentation: string_validator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: The variable name '_default_normalize_email_options' isn't a lowerCamelCase identifier.

lib/src/sanitizer.dart:4:21

  ╷
4 │ Map<String, Object> _default_normalize_email_options = {'lowercase': true};
  │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/sanitizer.dart

INFO: The variable name 'keep_new_lines' isn't a lowerCamelCase identifier.

lib/src/sanitizer.dart:100:35

    ╷
100 │ String stripLow(String str, [bool keep_new_lines = false]) {
    │                                   ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/sanitizer.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

354
likes
130
pub points
98%
popularity

Publisher

verified publishersuragch.dev

Dart library for validating and sanitizing strings, especially those from user input.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on string_validator