string_literal_finder 1.3.0+1 copy "string_literal_finder: ^1.3.0+1" to clipboard
string_literal_finder: ^1.3.0+1 copied to clipboard

Find non translated strings: Searches all dart files for string literals, excluding non translatable strings. Useful for i18n/l10n.

11
likes
120/ 160
pub points
87%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

53 out of 69 API elements (76.8 %) have documentation comments.

Some symbols that are missing documentation: analyser_plugin, analyser_plugin.start, string_literal_finder.AnalysisOptions, string_literal_finder.AnalysisOptions.AnalysisOptions, string_literal_finder.AnalysisOptions.debug.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:string_literal_finder/string_literal_finder.dart that imports:
  • package:string_literal_finder/src/string_literal_finder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:string_literal_finder/string_literal_finder.dart that imports:
  • package:string_literal_finder/src/string_literal_finder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:string_literal_finder/string_literal_finder.dart that imports:
  • package:string_literal_finder/src/string_literal_finder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'declaredElement2' is deprecated and shouldn't be used. Use declaredElement instead.

lib/src/string_literal_finder.dart:259:50

    ╷
259 │           if (nonNlsChecker.hasAnnotationOf(node.declaredElement2!)) {
    │                                                  ^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/string_literal_finder.dart

INFO: 'element2' is deprecated and shouldn't be used. Use element instead.

lib/src/string_literal_finder.dart:305:52

    ╷
305 │                 .isAssignableFrom(node.staticType!.element2!)) {
    │                                                    ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/string_literal_finder.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=4.5.0 <6.0.0 5.13.0 6.7.0
analyzer_plugin >=0.7.0 <0.12.0 0.11.2 0.11.3
args >=2.0.0 <3.0.0 2.5.0 2.5.0
glob >=2.0.0 <3.0.0 2.1.2 2.1.2
logging >=1.0.0 <2.0.0 1.2.0 1.2.0
logging_appenders >=1.0.0 <2.0.0 1.3.1 1.3.1
path >=1.8.0 <2.0.0 1.9.0 1.9.0
recase >=4.0.0 <5.0.0 4.1.0 4.1.0
source_gen >=1.0.2 <2.0.0 1.5.0 1.5.0
string_literal_finder_annotations ^1.0.0 1.0.0 1.0.0
yaml >=3.1.0 <4.0.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 72.0.0
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
dio - 5.5.0+1 5.5.0+1
dio_web_adapter - 1.0.1 1.0.1
file - 7.0.0 7.0.0
http_parser - 4.1.0 4.1.0
intl - 0.19.0 0.19.0
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.5.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 4 errors:

  • NON_ABSTRACT_CLASS_INHERITS_ABSTRACT_MEMBER - lib/src/plugin.dart:23:7 - Missing concrete implementation of 'ServerPlugin.createAnalysisDriver'.
  • NOT_ENOUGH_POSITIONAL_ARGUMENTS - lib/src/plugin.dart:25:15 - 1 positional argument expected by 'ServerPlugin.new', but 0 found.
  • UNDEFINED_NAMED_PARAMETER - lib/src/plugin.dart:25:15 - The named parameter 'resourceProvider' isn't defined.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

11
likes
120
pub points
87%
popularity

Publisher

verified publishercodeux.design

Find non translated strings: Searches all dart files for string literals, excluding non translatable strings. Useful for i18n/l10n.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

analyzer, analyzer_plugin, args, glob, logging, logging_appenders, path, recase, source_gen, string_literal_finder_annotations, yaml

More

Packages that depend on string_literal_finder