stateful_bloc 1.0.0 copy "stateful_bloc: ^1.0.0" to clipboard
stateful_bloc: ^1.0.0 copied to clipboard

Extension to the Bloc library that simplifies common state transition sequences

0
likes
150/ 160
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/stasgora/bloc-extensions/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

62 out of 62 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^7.1.0 7.2.1 8.1.4
equatable ^2.0.0 2.0.5 2.0.5
meta ^1.3.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.1.0` on bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
150
pub points
0%
popularity

Publisher

verified publishersgora.dev

Extension to the Bloc library that simplifies common state transition sequences

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, equatable, meta

More

Packages that depend on stateful_bloc