stagexl 2.0.0
stagexl: ^2.0.0 copied to clipboard

A fast and universal 2D rendering engine for HTML5 and Dart.

24
likes
90 / 130
pub points
68 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

Documentation URL is insecure.

Update the documentation field and use a secure (https) URL.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 5 links are insecure.

README.md:39:28

   ╷
39 │ <li>StageXL StackOverflow: <a href="http://stackoverflow.com/questions/ask?tags=stagexl">http://stackoverflow.com/questions/ask?tags=stagexl</a></li>
   │                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:8:28

  ╷
8 │ <li>StageXL StackOverflow: <a href="http://stackoverflow.com/questions/ask?tags=stagexl">http://stackoverflow.com/questions/ask?tags=stagexl</a></li>
  │                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 736 out of 2737 API elements (26.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:stagexl/stagexl.dart that imports:
  • package:stagexl/src/text.dart that imports:
  • package:stagexl/src/engine.dart that imports:
  • dart:web_gl
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
xml^5.0.05.1.25.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
meta-1.4.01.4.0
petitparser-4.2.04.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Dart 2.13.3.

24
likes
90
pub points
68%
popularity

Publisher

Unknown

A fast and universal 2D rendering engine for HTML5 and Dart.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

BSD (LICENSE.md)

Dependencies

xml

More

Packages that depend on stagexl