sse 3.3.0
sse: ^3.3.0 copied to clipboard

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

16
likes
80/ 130
pub points
98%
popularity

We analyzed this package 9 days ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 19 API elements (57.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:sse/client/sse_client.dart that imports:
  • dart:html
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.0.82.8.22.8.2
logging^0.11.3+20.11.41.0.2
pedantic^1.4.01.11.11.11.1
shelf^0.7.40.7.91.2.0
stream_channel>=1.6.8 <3.0.02.1.02.1.0
uuid^2.0.02.2.23.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.11.3+2` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

The constraint `^0.7.4` on shelf does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions shelf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

16
likes
80
pub points
98%
popularity

Publisher

tools.dart.dev

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

async, logging, pedantic, shelf, stream_channel, uuid

More

Packages that depend on sse