sqljocky5 2.2.1
sqljocky5: ^2.2.1 copied to clipboard

MySQL driver for Dart

12
likes
60/ 130
pub points
73%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 53 out of 462 API elements (11.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Tag detection failed.

Could not resolve import: package:logging/logging.dart

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.1.31.15.01.15.0
crypto^2.0.62.1.53.0.1
synchronized^1.5.11.5.3+23.0.0
typed_buffer^2.1.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
convert-2.1.13.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.6` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^1.5.1` on synchronized does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions synchronized to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Dart 2.14.1.