typed_buffer 2.2.1

typed_buffer #

Read and write typed data from binary buffer.

2.2.1 #

  • Introduced reading integer lists to ReadBuffer

example/typed_buffer_example.dart

import 'package:typed_buffer/typed_buffer.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  typed_buffer: ^2.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:typed_buffer/typed_buffer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
93
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:typed_buffer/typed_buffer.dart.

Health suggestions

Fix lib/src/fixed_write_buffer.dart. (-7.24 points)

Analysis of lib/src/fixed_write_buffer.dart reported 15 hints, including:

line 43 col 3: Prefer using /// for doc comments.

line 48 col 3: Prefer using /// for doc comments.

line 53 col 3: Prefer using /// for doc comments.

line 58 col 3: Prefer using /// for doc comments.

line 68 col 3: Prefer using /// for doc comments.

Maintenance suggestions

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
Dev dependencies
test ^1.0.0

Admin