sqlite3 2.4.0 copy "sqlite3: ^2.4.0" to clipboard
sqlite3: ^2.4.0 copied to clipboard

Provides lightweight yet convenient bindings to SQLite by using dart:ffi

273
likes
120/ 140
pub points
97%
popularity

We analyzed this package 19 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

358 out of 415 API elements (86.3 %) have documentation comments.

Some symbols that are missing documentation: open.OperatingSystem, open.OperatingSystem.OperatingSystem, sqlite3.wasm.AllowedArgumentCount.allowedArgs, sqlite3.wasm.AllowedArgumentCount.AllowedArgumentCount.any, sqlite3.wasm.BaseVfsFile.xDeviceCharacteristics.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:sqlite3/sqlite3.dart that imports:
  • package:sqlite3/src/ffi/api.dart that imports:
  • package:sqlite3/src/ffi/implementation.dart that imports:
  • package:sqlite3/src/ffi/sqlite3.g.dart that imports:
  • dart:ffi
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/ffi/bindings.dart:341:13

    ╷
341 │         sql.elementAt(byteOffset).cast(),
    │             ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ffi/bindings.dart

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/ffi/bindings.dart:356:13

    ╷
356 │         sql.elementAt(byteOffset).cast(),
    │             ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ffi/bindings.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
ffi >=1.2.1 <3.0.0 2.1.2 2.1.2
js ^0.6.4 0.6.7 0.7.1
meta ^1.3.0 1.12.0 1.12.0
path ^1.8.0 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.4` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.

273
likes
120
pub points
97%
popularity

Publisher

verified publishersimonbinder.eu

Provides lightweight yet convenient bindings to SQLite by using dart:ffi

Repository (GitHub)
View/report issues

Topics

#sql #database #ffi

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, ffi, js, meta, path

More

Packages that depend on sqlite3