sqlite3 2.4.2 copy "sqlite3: ^2.4.2" to clipboard
sqlite3: ^2.4.2 copied to clipboard

Provides lightweight yet convenient bindings to SQLite by using dart:ffi

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add sqlite3

With Flutter:

 $ flutter pub add sqlite3

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  sqlite3: ^2.4.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:sqlite3/sqlite3.dart';
291
likes
140
pub points
97%
popularity

Publisher

verified publishersimonbinder.eu

Provides lightweight yet convenient bindings to SQLite by using dart:ffi

Repository (GitHub)
View/report issues

Topics

#sql #database #ffi

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, ffi, js, meta, path

More

Packages that depend on sqlite3