sqflite_preferences 0.0.9
sqflite_preferences: ^0.0.9 copied to clipboard

sqflite preferences is an approach to simulate the shared preferences behaveir through sqflite library

0
likes
80/ 130
pub points
38%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 19 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:sqflite_preferences/sqflite_preferences.dart that imports:
  • package:sqflite_preferences/dbHelper.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path^1.7.01.8.01.8.0
path_provider^1.6.271.6.282.0.7
sqflite^1.3.2+31.3.2+42.0.0+4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
sqflite_common-1.0.3+32.0.1+1
synchronized-2.2.0+23.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.6.27` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

The constraint `^1.3.2+3` on sqflite does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sqflite to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
80
pub points
38%
popularity

sqflite preferences is an approach to simulate the shared preferences behaveir through sqflite library

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, path, path_provider, sqflite

More

Packages that depend on sqflite_preferences