sqflite_common_ffi 2.0.0+3
sqflite_common_ffi: ^2.0.0+3 copied to clipboard

sqflite ffi based implementation, for desktop and units tests.

67
likes
130/ 130
pub points
96%
popularity

We analyzed this package on Sep 17, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 5 API elements (80.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta>=1.3.0 <3.0.01.7.01.7.0
path>=1.8.0 <3.0.01.8.01.8.0
sqflite_common>=2.0.1 <4.0.02.0.1+12.0.1+1
sqlite3>=1.0.0 <3.0.01.2.01.2.0
synchronized>=3.0.0 <5.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
ffi-1.1.21.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Dart 2.14.1.

67
likes
130
pub points
96%
popularity

sqflite ffi based implementation, for desktop and units tests.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

meta, path, sqflite_common, sqlite3, synchronized

More

Packages that depend on sqflite_common_ffi