spring 2.0.2
spring: ^2.0.2 copied to clipboard

A simple & powerfull pre-built animation kit for faster and easy apps developement.

147
likes
100/ 130
pub points
88%
popularity

We analyzed this package 33 hours ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 44 API elements (47.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/src/enums.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/sized_context.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
simple_animations^3.1.13.2.04.0.1
supercharged^2.0.02.1.12.1.1
universal_platform^1.0.0-nullsafety1.0.0+11.0.0+1
vector_math^2.1.02.1.02.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
flutter_lints-1.0.41.0.4
lints-1.0.11.0.1
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
supercharged_dart-2.1.12.1.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.1` on simple_animations does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions simple_animations to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

147
likes
100
pub points
88%
popularity

A simple & powerfull pre-built animation kit for faster and easy apps developement.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, simple_animations, supercharged, universal_platform, vector_math

More

Packages that depend on spring