spotify_sdk 1.0.0
spotify_sdk: ^1.0.0 copied to clipboard

Flutter Android iOS web

A flutter plugin that let's you communicate with the spotify sdk and auth lib

35
likes
90 / 110
pub points
81 %
popularity

We analyzed this package on Jan 18, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  error: failed to write file at: spotify_sdk/ImageDimensionExtension/values-constant.html, for symbol spotify_sdk.ImageDimensionExtension.values: (file:///tmp/pub-dartlang-dartdocRUFEJJ/pkg/lib/spotify_sdk.dart:566:16)
            Dartdoc generates a path and filename to write to for each symbol.
            spotify_sdk.ImageDimensionExtension.values conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: spotify_sdk_web has no library level documentation comments, from spotify_sdk_web: (file:///tmp/pub-dartlang-dartdocRUFEJJ/pkg/lib/spotify_sdk_web.dart:2:9)
  warning: dartdoc generated a broken link to: example/lib/main.dart, linked to from package-spotify_sdk: file:///tmp/pub-dartlang-dartdocRUFEJJ/pkg
found 2 warnings and 1 error
Unhandled exception:
dartdoc encountered 1 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:231:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:spotify_sdk/spotify_sdk.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'messenger' is deprecated and shouldn't be used. This property is redundant. It returns the object on which it is called. This feature was deprecated after v1.24.0-7.0.pre..

lib/spotify_sdk_web.dart:99:48

   ╷
99 │         const StandardMethodCodec(), registrar.messenger);
   │                                                ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/spotify_sdk_web.dart

INFO: Close instances of `dart.core.Sink`.

lib/spotify_sdk_web.dart:103:11

    ╷
103 │     final playerContextEventController = StreamController.broadcast();
    │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/spotify_sdk_web.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.52.1.52.1.5
dio^3.0.103.0.103.0.10
js^0.6.20.6.3-nullsafety.30.6.3-nullsafety.3
json_annotation^3.1.03.1.13.1.1
logger^0.9.40.9.40.9.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

35
likes
90
pub points
81%
popularity

A flutter plugin that let's you communicate with the spotify sdk and auth lib

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

tobiasbusch90@gmail.com

License

MIT (LICENSE)

Dependencies

crypto, dio, flutter, flutter_web_plugins, js, json_annotation, logger

More

Packages that depend on spotify_sdk