sponge_grpc_client_dart 1.16.2

Dart native
Flutter Android iOS

Sponge gRPC client for Dart. It simplifies connecting to a remote Sponge gRPC service.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Sep 18, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 45 API elements (28.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:sponge_grpc_client_dart/sponge_grpc_client_dart.dart that imports:
  • package:sponge_grpc_client_dart/src/grpc_client.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/src/generated/google/protobuf/any.pbjson.dart:8:18

   ╷
8  │   const Any$json = const {
   │ ┌──────────────────^
9  │ │   '1': 'Any',
10 │ │   '2': const [
11 │ │     const {'1': 'type_url', '3': 1, '4': 1, '5': 9, '10': 'typeUrl'},
12 │ │     const {'1': 'value', '3': 2, '4': 1, '5': 12, '10': 'value'},
13 │ │   ],
14 │ │ };
   │ └─^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generated/google/protobuf/any.pbjson.dart

INFO: Avoid const keyword.

lib/src/generated/google/protobuf/any.pbjson.dart:10:8

   ╷
10 │     '2': const [
   │ ┌────────^
11 │ │     const {'1': 'type_url', '3': 1, '4': 1, '5': 9, '10': 'typeUrl'},
12 │ │     const {'1': 'value', '3': 2, '4': 1, '5': 12, '10': 'value'},
13 │ │   ],
   │ └───^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generated/google/protobuf/any.pbjson.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
fixnum^0.10.110.10.110.10.11
grpc^2.1.32.2.02.2.0
logging^0.11.40.11.40.11.4
meta^1.1.81.2.31.2.3
protobuf^1.0.11.0.11.0.1
sponge_client_dart^1.16.21.16.21.16.2
sync^0.2.00.2.00.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
convert-2.1.12.1.1
crypto-2.1.52.1.5
equatable-1.2.51.2.5
googleapis_auth-0.2.120.2.12
http-0.12.20.12.2
http2-1.0.01.0.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
matcher-0.12.90.12.9
path-1.7.01.7.0
quiver-2.1.32.1.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.1.0
timezone-0.5.70.5.7
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

Sponge gRPC client for Dart. It simplifies connecting to a remote Sponge gRPC service.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

marcin.pas@softelnet.com

License

Apache 2.0 (LICENSE)

Dependencies

fixnum, grpc, logging, meta, protobuf, sponge_client_dart, sync

More

Packages that depend on sponge_grpc_client_dart