spaceinvaders 2.0.8
spaceinvaders: ^2.0.8 copied to clipboard

Space-Invaders built with Material Design Lite 4 Dart

0
likes
50 / 130
pub points
0 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 3 links are insecure.

README.md:5:17

  ╷
5 │ <p>See it Live: <a href="http://spaceinvaders.mikemitterer.at">spaceinvaders.mikemitterer.at</a></p>
  │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 6 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-space-invaders/compare/v2.0...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 61 out of 229 API elements (26.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:spaceinvaders/spaceinvaders.dart that imports:
  • package:spaceinvaders/components.dart that imports:
  • package:m4d_components/m4d_components.dart that imports:
  • package:m4d_core/m4d_core.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

lib/components.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/components/ArcadeButtonComponent.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
logging>=0.11.3 <1.0.00.11.41.0.1
m4d_animation>=0.1.0 <1.0.00.1.40.1.4
m4d_components>=0.1.0 <1.0.00.1.310.1.31
m4d_core>=0.1.0 <1.0.00.2.210.2.21
m4d_flux>=0.1.0 <1.0.00.1.00.1.0
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.022.0.0
analyzer-0.39.171.7.1
ansicolor-1.1.12.0.1
args-1.6.02.1.1
async-2.7.02.7.0
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
cli_util-0.2.00.3.1
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.1
file-5.2.16.1.2
glob-1.2.02.0.1
html-0.14.0+40.15.0
intl-0.15.80.17.0
intl_translation-0.17.10+10.17.10+1
js-0.6.30.6.3
l10n-2.0.192.0.19
meta-1.4.01.4.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
optional-3.1.05.0.0+1
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-3.1.04.2.0
platform_detect-1.4.02.0.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
where-4.4.08.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

0
likes
50
pub points
0%
popularity

Publisher

Unknown

Space-Invaders built with Material Design Lite 4 Dart

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE.txt)

Dependencies

console_log_handler, logging, m4d_animation, m4d_components, m4d_core, m4d_flux, validate

More

Packages that depend on spaceinvaders