socket_io_common 2.0.3 copy "socket_io_common: ^2.0.3" to clipboard
socket_io_common: ^2.0.3 copied to clipboard

Socket.io common parser library.

5
likes
120/ 160
pub points
84%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/rikulo/socket_io_common/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 59 API elements (42.4 %) have documentation comments.

Some symbols that are missing documentation: socket_io_common.ACK, socket_io_common.BINARY_ACK, socket_io_common.BINARY_EVENT, socket_io_common.Binary, socket_io_common.Binary.Binary.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/src/engine/parser/parser.dart:50:15

   ╷
50 │       {dynamic? supportsBinary,
   │               ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/engine/parser/parser.dart

INFO: Dangling library doc comment.

lib/src/engine/parser/parser.dart:1:1

   ╷
1  │ ┌ /**
2  │ │  * parser.dart
3  │ │  *
4  │ │  * Purpose:
5  │ │  *
6  │ │  * Description:
7  │ │  *
8  │ │  * History:
9  │ │  *    20/02/2017, Created by jumperchen
10 │ │  *
11 │ │  * Copyright (C) 2017 Potix Corporation. All Rights Reserved.
12 │ └  */
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/engine/parser/parser.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
logging ^1.0.1 1.2.0 1.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

5
likes
120
pub points
84%
popularity

Publisher

unverified uploader

Socket.io common parser library.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

logging

More

Packages that depend on socket_io_common