smtp 1.0.0+1
smtp: ^1.0.0+1 copied to clipboard

An SMTP 5321 server implementation in Dart. Use this to receive e-mail messages within the Dart VM.

0
likes
70/ 130
pub points
37%
popularity

We analyzed this package 27 hours ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/thosakwe/smtp was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 46 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:smtp/smtp.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async>=1.0.0 <3.0.02.8.22.8.2
dart2_constant^1.0.01.0.2+dart21.0.2+dart2
http_parser^3.0.03.1.44.0.0
mime^0.9.00.9.71.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
meta-1.7.01.7.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on http_parser does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions http_parser to update the constraint.

The constraint `^0.9.0` on mime does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions mime to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
70
pub points
37%
popularity

An SMTP 5321 server implementation in Dart. Use this to receive e-mail messages within the Dart VM.

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, dart2_constant, http_parser, mime

More

Packages that depend on smtp