skyscrapeapi 3.0.0+5 icon indicating copy to clipboard operation
skyscrapeapi: ^3.0.0+5 copied to clipboard

SkyMobile API is the API that was taken from the original SkyMobile app. SkyMobile API allows easy Skyward access for developers.

2
likes
90/ 130
pub points
23%
popularity

We analyzed this package 23 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 58 out of 197 API elements (29.4 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 2 possible platforms (native, js)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/data_types.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/sky_core.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.14.0+20.14.0+40.15.0
http^0.12.0+20.12.20.13.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
csslib-0.16.20.17.1
http_parser-3.1.44.0.0
path-1.8.11.8.1
pedantic-1.11.11.11.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0+2` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

2
likes
90
pub points
23%
popularity

Publisher

shield icon for verified publishersclearhall.dev

SkyMobile API is the API that was taken from the original SkyMobile app. SkyMobile API allows easy Skyward access for developers.

Repository (GitHub)
View/report issues

Documentation

API reference

License

AGPL-3.0 (LICENSE)

Dependencies

html, http

More

Packages that depend on skyscrapeapi