skydroid_cli 0.1.0+1

Dart native
Flutter Android iOS

Command-line tool for SkyDroid app distribution.

1
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 20 API elements (30.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:skydroid_cli/commands/init.dart that imports:
  • package:io/ansi.dart that imports:
  • package:io/src/ansi_code.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Use `;` instead of `{}` for empty constructor bodies.

lib/commands/init.dart:14:17

   ╷
14 │   InitCommand() {}
   │                 ^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/commands/init.dart

INFO: Unused import: 'package:async/async.dart'.

lib/commands/publish.dart:11:8

   ╷
11 │ import 'package:async/async.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/commands/publish.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.0.01.6.01.6.0
async^2.4.22.4.22.4.2
crypto^2.1.52.1.52.1.5
http^0.12.00.12.20.12.2
io^0.3.40.3.40.3.4
path^1.0.01.7.01.7.0
prompts^1.0.01.3.11.3.1
yaml^2.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
meta-1.2.31.2.3
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
0%
popularity

Command-line tool for SkyDroid app distribution.

Homepage

Documentation

API reference

Uploader

xxredsolverxx@gmail.com

License

MIT (LICENSE)

Dependencies

args, async, crypto, http, io, path, prompts, yaml

More

Packages that depend on skydroid_cli