skeletonizer 1.4.1+1 copy "skeletonizer: ^1.4.1+1" to clipboard
skeletonizer: ^1.4.1+1 copied to clipboard

Converts already built widgets into skeleton loaders with no extra effort.

961
likes
150/ 160
pub points
99%
popularity

We analyzed this package 12 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

153 out of 156 API elements (98.1 %) have documentation comments.

Some symbols that are missing documentation: skeletonizer, skeletonizer.BoneRenderObject.decoration, skeletonizer.BoneRenderObject.textDirection.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/skeletonizer_config.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

961
likes
150
pub points
99%
popularity
screenshot

Publisher

verified publishercodeness.ly

Converts already built widgets into skeleton loaders with no extra effort.

Repository (GitHub)
View/report issues

Topics

#skeleton #shimmer-loading #skeleton-loader #loading

Documentation

API reference

License

MIT (license)

Dependencies

collection, flutter

More

Packages that depend on skeletonizer