sk_alert_dialog 1.0.0
sk_alert_dialog: ^1.0.0 copied to clipboard

A highly customizable, powerful and easy-to-use alert dialog for Flutter.

18
likes
80 / 130
pub points
72 %
popularity

We analyzed this package on May 4, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 12 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:sk_alert_dialog/sk_alert_dialog.dart that imports:
  • package:sk_alert_dialog/src/widgets/sk_alert_textfield.dart that imports:
  • package:google_fonts/google_fonts.dart that imports:
  • package:google_fonts/src/google_fonts_base.dart that imports:
  • package:google_fonts/src/file_io_desktop_and_mobile.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/widgets/sk_alert_checkbox.dart:92:35

   ╷
92 │                                   FlatButton(
   │                                   ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/widgets/sk_alert_checkbox.dart

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/widgets/sk_alert_checkbox.dart:110:35

    ╷
110 │                                   FlatButton(
    │                                   ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/widgets/sk_alert_checkbox.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
google_fonts^1.1.01.1.22.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on google_fonts does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions google_fonts to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

18
likes
80
pub points
72%
popularity

A highly customizable, powerful and easy-to-use alert dialog for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

senthilece01@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, google_fonts

More

Packages that depend on sk_alert_dialog