simple_markdown_editor 0.2.0 copy "simple_markdown_editor: ^0.2.0" to clipboard
simple_markdown_editor: ^0.2.0 copied to clipboard

A TextField Widget that allow you to convert easily what's in the TextField to Markdown.

33
likes
120/ 140
pub points
75%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

45 out of 94 API elements (47.9 %) have documentation comments.

Some symbols that are missing documentation: image_network, image_network.ImageNetworkMarkdown, image_network.ImageNetworkMarkdown.ImageNetworkMarkdown, image_network.ImageNetworkMarkdown.title, image_network.ImageNetworkMarkdown.uri.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'hashValues' is deprecated and shouldn't be used. Use Object.hash() instead. This feature was deprecated in v3.1.0-0.0.pre.897.

lib/src/emoji_parser.dart:96:23

   ╷
96 │   int get hashCode => hashValues(name.hashCode, code.hashCode);
   │                       ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/emoji_parser.dart

INFO: 'toolbarOptions' is deprecated and shouldn't be used. Use `contextMenuBuilder` instead. This feature was deprecated after v3.3.0-0.5.pre.

lib/widgets/markdown_field.dart:129:11

    ╷
129 │           toolbarOptions: const ToolbarOptions(
    │           ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/markdown_field.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
expandable ^5.0.1 5.0.1 5.0.1
flutter flutter 0.0.0 0.0.0
flutter_markdown ^0.6.6 0.6.9+1 0.6.20+1
font_awesome_flutter ^9.1.0 9.2.0 10.7.0
markdown ^4.0.0 4.0.1 7.2.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^9.1.0` on font_awesome_flutter does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions font_awesome_flutter to update the constraint.

The constraint `^4.0.0` on markdown does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions markdown to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

33
likes
120
pub points
75%
popularity

Publisher

verified publishermokuton.site

A TextField Widget that allow you to convert easily what's in the TextField to Markdown.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

expandable, flutter, flutter_markdown, font_awesome_flutter, markdown

More

Packages that depend on simple_markdown_editor