simple_formatted_text 0.0.1+1 copy "simple_formatted_text: ^0.0.1+1" to clipboard
simple_formatted_text: ^0.0.1+1 copied to clipboard

Simple formatted text. Made to be configured with the string, like MD but simplest

9
likes
150/ 160
pub points
41%
popularity

We analyzed this package 3 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 15 API elements (26.7 %) have documentation comments.

Some symbols that are missing documentation: simple_formatted_text, simple_formatted_text.SimpleFormattedText, simple_formatted_text.SimpleFormattedText.colorFromHexStr, simple_formatted_text.SimpleFormattedText.colorToHexStr, simple_formatted_text.SimpleFormattedText.linkTextStyle.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Statements in an if should be enclosed in a block.

lib/src/widget.dart:83:17

   ╷
83 │                 sections.add(TextSpan(text: ss, style: lastStyle));
   │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widget.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

9
likes
150
pub points
41%
popularity

Publisher

verified publishervazquezmarcos.es

Simple formatted text. Made to be configured with the string, like MD but simplest

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on simple_formatted_text