similo 1.0.3

Dart native

Dart Builder for const constructors and copyWith

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:similo/similo.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Use isNotEmpty instead of length

lib/src/class_generator.dart:87:29

   ╷
87 │     final allConstWrapped = allValues.length > 0 ? "{$allConst}" : allConst;
   │                             ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/class_generator.dart

INFO: This function has a return type of 'ElementAnnotation', but doesn't end with a return statement.

lib/src/custom_modifier_generator.dart:44:19

   ╷
44 │           orElse: () {});
   │                   ^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/custom_modifier_generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.38.20.38.50.40.3
build^1.1.61.5.01.5.0
similo_annotations^1.0.31.0.31.0.3
source_gen^0.9.00.9.4+60.9.7+1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.31.3.7
front_end-0.1.270.1.29
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
kernel-0.3.270.3.29
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.38.2` on analyzer does not support the latest published version `0.40.3`

pubspec.yaml:14:13

   ╷
14 │   analyzer: ^0.38.2
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
40
pub points
0%
popularity

Dart Builder for const constructors and copyWith

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

yunusgnr@gmail.com

License

BSD (LICENSE)

Dependencies

analyzer, build, similo_annotations, source_gen

More

Packages that depend on similo