show_dialog 1.0.3 icon indicating copy to clipboard operation
show_dialog: ^1.0.3 copied to clipboard

A Package for Launch Dialogs As Easy As Poosible Like About Dialog, Loading Dialog and Many More

4
likes
80/ 140
pub points
45%
popularity

We analyzed this package 5 days ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 3 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

lib/show_dialog.dart:20:11

   ╷
20 │ ┌           new FlatButton(
21 │ │             child: new Text("Close"),
22 │ │             onPressed: () {
23 │ │               Navigator.of(context).pop();
24 │ │             },
25 │ │           ),
   │ └───────────^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/show_dialog.dart

ERROR: The name 'FlatButton' isn't a class.

lib/show_dialog.dart:20:15

   ╷
20 │           new FlatButton(
   │               ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/show_dialog.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

4
likes
80
pub points
45%
popularity

Publisher

verified publisher icondplyr.dev

A Package for Launch Dialogs As Easy As Poosible Like About Dialog, Loading Dialog and Many More

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on show_dialog