show_dialog 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Show Dialog Package #

##Importing:

import 'package:show_dialog/show_dialog.dart' as dialog;

About Dialog #

Launches About Dialog with title and content with one line of code #

Example: #
dialog.aboutDialog(context, 'title', 'content');

Loading Dialog #

Launches Loading Dialog with one line of code #

Example: #
dialog.loadingDialog(context, 2);

[1.0.3] - 2019-03-03 6:11:00 pm

  • Fix bug when calling showAboutDialog

[1.0.2] - 2019-03-03 4:05:00 pm

  • Added Example & Updated Documentation

[1.0.1] - 2019-03-01 5:34:00 pm

  • Updated Documentation

[1.0.0] - 2019-03-01 5:30:00 pm

  • Inital Release

example/main.dart

import 'package:flutter/material.dart';
import 'package:show_dialog/show_dialog.dart' as dialog;

class MyApp extends StatelessWidget{
  @override
  Widget build (BuildContext context){
    return Scaffold(
      body: Column(
        children: <Widget> [
          Container(
            child: RaisedButton(
              child: Text("About Dialog"),
              onPressed: (){
                dialog.aboutDialog(context, "title", "content");
              }
            ),
          ),
          Container(
            child: RaisedButton(
              child: Text("Loading Dialog"),
              onPressed: (){
                dialog.loadingDialog(context, 3);
              }
            ),
          ),
        ]
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  show_dialog: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:show_dialog/show_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

3 out of 3 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/show_dialog.dart.

Run flutter format to format lib/show_dialog.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test