sftp_explorer_and_streaming 0.0.2
sftp_explorer_and_streaming: ^0.0.2 copied to clipboard

a package that give ability to explore file and stream by sftp.

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 30 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:sftp_explorer_and_streaming/sftp_explorer_and_streaming.dart that imports:
  • package:sftp_explorer_and_streaming/video_dir.dart that imports:
  • package:better_player/better_player.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/image_streamer.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/video_dir.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
better_player^0.0.690.0.790.0.79
filesize^2.0.12.0.12.0.1
flutterflutter0.0.00.0.0
flutter_slidable^0.6.00.6.01.1.0
fluttertoast^8.0.78.0.88.0.8
photo_view^0.11.10.11.10.13.0
ssh^0.0.70.0.70.0.7
url_launcher^6.0.66.0.156.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.17.10.17.1
cupertino_icons-1.0.41.0.4
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.7.00.8.2
html-0.15.00.15.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
visibility_detector-0.2.20.2.2
wakelock-0.5.60.5.6
wakelock_macos-0.4.00.4.0
wakelock_platform_interface-0.3.00.3.0
wakelock_web-0.4.00.4.0
wakelock_windows-0.2.00.2.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on flutter_slidable does not support the stable version `1.0.0`, that was published 14 days ago.

When flutter_slidable is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_slidable to update the constraint.

The constraint `^0.11.1` on photo_view does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

1
likes
70
pub points
0%
popularity

a package that give ability to explore file and stream by sftp.

Homepage

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

better_player, filesize, flutter, flutter_slidable, fluttertoast, photo_view, ssh, url_launcher

More

Packages that depend on sftp_explorer_and_streaming