settings_yaml 8.0.1 copy "settings_yaml: ^8.0.1" to clipboard
settings_yaml: ^8.0.1 copied to clipboard

Provides a simple means of saving/loading settings from a yaml file without the yaml fuss.

15
likes
140/ 140
pub points
78%
popularity

We analyzed this package 33 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 33 API elements (69.7 %) have documentation comments.

Some symbols that are missing documentation: settings_yaml, settings_yaml.PathNotFoundException, settings_yaml.PathNotFoundException.PathNotFoundException, settings_yaml.PathNotFoundException.message, settings_yaml.SettingsYaml.filePath.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:settings_yaml/settings_yaml.dart that imports:
  • package:settings_yaml/src/settings_yaml.dart that imports:
  • package:dcli_core/dcli_core.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
dcli_core ^3.3.1 3.4.0 3.4.0
meta ^1.3.0 1.14.0 1.14.0
path ^1.8.0 1.9.0 1.9.0
uuid ^4.0.0 4.4.0 4.4.0
yaml ^3.0.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
circular_buffer - 0.11.0 0.11.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
logging - 1.2.0 1.2.0
scope - 4.1.0 4.1.0
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

15
likes
140
pub points
78%
popularity

Publisher

verified publisheronepub.dev

Provides a simple means of saving/loading settings from a yaml file without the yaml fuss.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, dcli_core, meta, path, uuid, yaml

More

Packages that depend on settings_yaml