sentry 4.0.0-beta.1
sentry: ^4.0.0-beta.1 copied to clipboard

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add sentry

With Flutter:

 $ flutter pub add sentry

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  sentry: ^4.0.0-beta.1

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:sentry/sentry.dart';
274
likes
90
pub points
98%
popularity

Publisher

sentry.io

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

Homepage
Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

http, meta, stack_trace, uuid

More

Packages that depend on sentry