sensors 2.0.3 copy "sensors: ^2.0.3" to clipboard
sensors: ^2.0.3 copied to clipboard

discontinued
PlatformAndroidiOS

Flutter plugin for accessing the Android and iOS accelerometer and gyroscope sensors.

384
likes
150/ 160
pub points
94%
popularity

We analyzed this package 5 days ago, and awarded it 150 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/flutter/plugins/tree/master/packages/sensors was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: sensors,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: sensors.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 19 API elements (94.7 %) have documentation comments.

Some symbols that are missing documentation: sensors.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:sensors/sensors.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:sensors/sensors.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:sensors/sensors.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:sensors/sensors.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

384
likes
150
pub points
94%
popularity

Publisher

verified publisherflutter.dev

Flutter plugin for accessing the Android and iOS accelerometer and gyroscope sensors.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter

More

Packages that depend on sensors