sembast_sqflite 2.0.0+1
sembast_sqflite: ^2.0.0+1 copied to clipboard

sembast NoSQL database support on top of sqflite, cross process safe database.

14
likes
130 / 130
pub points
82 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection>=1.15.0 <3.0.01.15.01.15.0
meta>=1.3.0 <3.0.01.7.01.7.0
sembast>=3.0.0 <5.0.03.1.0+23.1.0+2
sqflite_common>=2.0.0 <4.0.02.0.0+22.0.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
path-1.8.01.8.0
synchronized-3.0.03.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

14
likes
130
pub points
82%
popularity

Publisher

tekartik.com

sembast NoSQL database support on top of sqflite, cross process safe database.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection, meta, sembast, sqflite_common

More

Packages that depend on sembast_sqflite