select_any 1.0.3 copy "select_any: ^1.0.3" to clipboard
select_any: ^1.0.3 copied to clipboard

A flexible library for listing data in lists/tables

5
likes
30/ 160
pub points
37%
popularity

We analyzed this package 4 days ago, and awarded it 30 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
Because msk_utils >=2.0.0 depends on intl ^0.18.1 and select_any depends on intl ^0.19.0, msk_utils >=2.0.0 is forbidden.
So, because select_any depends on msk_utils >=2.0.0, version solving failed.
failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: flutter pub get failed:
OUT:
Resolving dependencies...
ERR:
Because msk_utils >=2.0.0 depends on intl ^0.18.1 and select_any depends on intl ^0.19.0, msk_utils >=2.0.0 is forbidden.
So, because select_any depends on msk_utils >=2.0.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
Because msk_utils >=2.0.0 depends on intl ^0.18.1 and select_any depends on intl ^0.19.0, msk_utils >=2.0.0 is forbidden.
So, because select_any depends on msk_utils >=2.0.0, version solving failed.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.