seeip_client 0.1.2 icon indicating copy to clipboard operation
seeip_client: ^0.1.2 copied to clipboard

A library that makes it easy to fetch data from SeeIP - A simple IP address API.

1
likes
90/ 140
pub points
48%
popularity

We analyzed this package 19 hours ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 47 API elements (19.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/models/geo_ip.dart:11:10

   ╷
11 │   String dma_code;
   │          ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/geo_ip.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/models/geo_ip.dart:12:10

   ╷
12 │   String area_code;
   │          ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/geo_ip.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.13.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.16.01.16.0
http_parser-3.1.44.0.1
path-1.8.21.8.2
pedantic-1.11.11.11.1
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.17, Dart 2.18.0.

1
likes
90
pub points
48%
popularity

Publisher

verified publisher iconmadaboutbrighton.net

A library that makes it easy to fetch data from SeeIP - A simple IP address API.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

http

More

Packages that depend on seeip_client