search_page 2.2.0 copy "search_page: ^2.2.0" to clipboard
search_page: ^2.2.0 copied to clipboard

Fast and easy way to build a custom search experience in you app

182
likes
90/ 140
pub points
94%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 23 API elements (78.3 %) have documentation comments.

Some symbols that are missing documentation: search_page, search_page.ResultBuilder, search_page.SearchFilter, search_page.SearchPage.sort, search_page.SortCallback.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: The named parameter 'headline6' isn't defined.

lib/search_page.dart:95:17

   ╷
95 │                 headline6: TextStyle(
   │                 ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/search_page.dart

ERROR: The getter 'headline6' isn't defined for the type 'TextTheme'.

lib/search_page.dart:96:61

   ╷
96 │                   color: Theme.of(context).primaryTextTheme.headline6?.color,
   │                                                             ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/search_page.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

182
likes
90
pub points
94%
popularity

Publisher

verified publisherjesusrp98.page

Fast and easy way to build a custom search experience in you app

Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on search_page