sealed_flutter_bloc 8.0.2 copy "sealed_flutter_bloc: ^8.0.2" to clipboard
sealed_flutter_bloc: ^8.0.2 copied to clipboard

flutter_bloc state management extension that integrates sealed_unions.

79
likes
120/ 140
pub points
69%
popularity

We analyzed this package 8 days ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/felangel/sealed_flutter_bloc/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

161 out of 549 API elements (29.3 %) have documentation comments.

Some symbols that are missing documentation: sealed_flutter_bloc.Doublet, sealed_flutter_bloc.Doublet.Doublet, sealed_flutter_bloc.Doublet.first, sealed_flutter_bloc.Doublet.second, sealed_flutter_bloc.Factory0.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Doc directive 'm?acro' is unknown.

lib/src/sealed_bloc_builder/sealed_bloc_builder2.dart:30:9

   ╷
30 │   /// {@m?acro sealedblocwidgetbuilder}
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/sealed_bloc_builder/sealed_bloc_builder2.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.0.0 8.1.4 8.1.4
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.0.0 8.1.5 8.1.5
sealed_unions ^3.0.3+1 3.0.3+1 3.0.3+1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.