scrolling_years_calendar 1.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

Flutter Scrolling Calendar 🗓 #

A customizable calendar widget to easily scroll through the years

pub version

Screenshot

Features #

  • Choose range of years and the initial year to show
  • Callback on month-tap with date information
  • Choose the color of the current day indicator
  • Override the default month names

Planned Features #

  • Customizable color indications per date
  • Allow for better customization of elements
  • Zoom-in to month view on tap in year-view
  • Zoom-in to day view on tap in month-view
  • Infinite scrolling

Contributors #

1.2.0 #

  • Highlighted dates feature.
  • Breaking change. Renamed color property, which is now required.
  • Breakpoint bug fix.

1.1.0 #

  • Major refactor.
  • Breaking change. Renamed properties.
  • Breaking change. Require Flutter 1.5.0.

1.0.0 #

  • Initial release.

example/README.md

scrolling_years_calendar_example #

Demonstrates how to use the scrolling_years_calendar plugin.

Getting Started #

For help getting started with Flutter, view its online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scrolling_years_calendar: ^1.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scrolling_years_calendar/scrolling_years_calendar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.2

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test