screen_brightness_util 0.0.3 copy "screen_brightness_util: ^0.0.3" to clipboard
screen_brightness_util: ^0.0.3 copied to clipboard

A flutter plugin to config and monitor brightness. Support Windows, Android and iOS platform.

2
likes
140/ 140
pub points
65%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 12 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: screen_brightness_util, screen_brightness_util.PlatformChannel, screen_brightness_util.PlatformChannel.PlatformChannel, screen_brightness_util.PlatformChannel.getBrightness, screen_brightness_util.PlatformChannel.onBrightnessChange.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:screen_brightness_util/screen_brightness_util.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `macOS`.

Because:

  • package:screen_brightness_util/screen_brightness_util.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `Web`.

Because:

  • package:screen_brightness_util/screen_brightness_util.dart that declares support for platforms: Android, iOS, Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
screen_brightness_util_android ^0.0.2 0.0.2 0.0.2
screen_brightness_util_ios ^0.0.2 0.0.2 0.0.2
screen_brightness_util_platform_interface ^0.0.2 0.0.2 0.0.2
screen_brightness_util_windows ^0.0.2 0.0.2 0.0.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.