scidart_plot 0.0.1-dev.2
scidart_plot: ^0.0.1-dev.2 copied to clipboard

SciDart Plot is a data visualization library compatible with SciDart. This library is part of SciDart project. The main goal is Generate and save plots in SVG format.

0
likes
70 / 110
pub points
26 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/scidart_plot_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 236 API elements (12.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:scidart_plot/scidart_plot.dart that imports:
  • package:scidart_plot/src/svg/svg.dart that imports:
  • package:scidart_plot/src/svg/canvas/svg_canvas.dart that imports:
  • package:scidart_io/scidart_io.dart that imports:
  • package:scidart_io/src/io/io.dart that imports:
  • package:scidart_io/src/io/txt/write_txt.dart that imports:
  • package:scidart_io/src/io/path/retrieve_file_path.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: This function has a return type of 'SvgWidget', but doesn't end with a return statement.

lib/src/plot/curve.dart:5:11

  ╷
5 │ SvgWidget curve(
  │           ^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/plot/curve.dart

lib/scidart_plot.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
color^2.1.12.1.13.0.0
meta^1.1.71.3.01.3.0
scidart^0.0.1-dev.80.0.1-dev.120.0.1-dev.12
scidart_io^0.0.1-dev.50.0.1-dev.60.0.1-dev.6
Transitive dependencies
PackageConstraintCompatibleLatest
path-1.8.01.8.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.1` on color does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions color to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
70
pub points
26%
popularity

SciDart Plot is a data visualization library compatible with SciDart. This library is part of SciDart project. The main goal is Generate and save plots in SVG format.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

angelopolotto@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

color, meta, scidart, scidart_io

More

Packages that depend on scidart_plot