scidart_io 0.0.1-dev.6
scidart_io: ^0.0.1-dev.6 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

SciDart IO is file manipulation library compatible with SciDart. This library is part of SciDart project https://scidart.org/).

0
likes
90 / 110
pub points
41 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/scidart_io_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 7 API elements (85.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:scidart_io/scidart_io.dart that imports:
  • package:scidart_io/src/io/io.dart that imports:
  • package:scidart_io/src/io/txt/write_txt.dart that imports:
  • package:scidart_io/src/io/path/retrieve_file_path.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/io/csv/read_csv.dart:38:21

   ╷
38 │   List<List> data = List();
   │                     ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/io/csv/read_csv.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/io/csv/read_csv.dart:43:18

   ╷
43 │     List rows2 = List();
   │                  ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/io/csv/read_csv.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.6.41.8.01.8.0
scidart^0.0.1-dev.80.0.1-dev.120.0.1-dev.12

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

0
likes
90
pub points
41%
popularity

SciDart IO is file manipulation library compatible with SciDart. This library is part of SciDart project https://scidart.org/).

Homepage

Documentation

API reference

Uploader

angelopolotto@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

path, scidart

More

Packages that depend on scidart_io