sci_mobile_components 1.0.6

Flutter Android iOS web

Mobile UI component for SCI mobile project.

0
likes
80 / 110
pub points
25 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 137 API elements (14.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
fl_chart^0.10.00.10.10.11.1
flutterflutter0.0.00.0.0
flutter_vector_icons^0.2.10.2.10.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
equatable-1.2.51.2.5
meta-1.1.81.2.3
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.0` on fl_chart does not support the latest published version `0.11.1`

pubspec.yaml:14:13

   ╷
14 │   fl_chart: ^0.10.0
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
25%
popularity

Mobile UI component for SCI mobile project.

Homepage

Documentation

API reference

Uploader

raka.khairil@gmail.com

License

MIT (LICENSE)

Dependencies

fl_chart, flutter, flutter_vector_icons

More

Packages that depend on sci_mobile_components